TOSECdev Forum

TOSEC Project => Database / Datfiles => Errors & Contributions => Topic started by: Smith on August 31, 2018, 10:14:21 AM

Title: Wrong character in Atari ST - Applications - [ST] (TOSEC-v2015-05-07_CM).dat ?
Post by: Smith on August 31, 2018, 10:14:21 AM
Good day guys

In "Atari ST - Applications - [ST] (TOSEC-v2015-05-07_CM).dat" file, there is a:

<game name="Desktop-Icons fr TOS 2, 3 und 4 v2.1 (1993)(-)(de)">
 <description>Desktop-Icons fr TOS 2, 3 und 4 v2.1 (1993)(-)(de)</description>
 <rom name="Desktop-Icons fr TOS 2, 3 und 4 v2.1 (1993)(-)(de).st" size="901120" crc="c3ca70cf" md5="98a43a95f618a43c5cac2dca36c7aacd" sha1="eaee613a39e3aa01386ab32855893406d805d2c9"/>

But the right title is "Desktop-Icons für TOS 2, 3 und 4 v2.1 (1993)(-)(de).zip"
I tried to check the encoding but the character (between the f and r) in the dat is a weird one not the german ü it's not displayable in UTF-8.


<game name="Desktop-Icons fr TOS 2, 3 und 4 v2.1 (1993)(-)(de)"> with Notepad
<game name="Desktop-Icons fr TOS 2, 3 und 4 v2.1 (1993)(-)(de)"> with WordPad



By consequences checking files failed with CMP.

Have a nice day
Regards
Title: Re: Wrong character in Atari ST - Applications - [ST] (TOSEC-v2015-05-07_CM).dat ?
Post by: Maddog on September 02, 2018, 07:23:36 PM
I confirm that the dat and filename didn't look well on my computer either. Thanks for reporting, it's always a big help for us!  :)

This is one of the reasons we resisted for a long time adding extended characters to allowed TOSEC filenames, their behavior is sometimes unpredictable between different programs and computers and I am quite sure more similar errors exist. Quite a shame the character set issues are impossible to standardize properly even in 2018!
OT: Recently I was renaming PC Engine roms and discovered to my surprise that Ootake (which is one of the best and more commonly used PCE emulators) fails to load any ROM that has extended characters like the umlauts in its' filename.

I have updated the dat, please test attachment below and tell me if it looks as it should. My computer does not have German installed and I just copied the character "ü" from Windows character map. On my side it looks good, but I would like to have a confirmation before commiting the change to the dat for the next release.

On a final note, anyone spotting errors please report! Things can go unnoticed for long times if noone tells about them!
Title: Re: Wrong character in Atari ST - Applications - [ST] (TOSEC-v2015-05-07_CM).dat ?
Post by: Smith on September 03, 2018, 03:53:58 PM
You're welcome.
Thanks I appreciate a lot, i'll check that :)