Author Topic: Fix for the Atari 5200 - Games datfile - Ballblazer  (Read 2225 times)

Offline Kr0tki

  • Newbie
  • *
  • Posts: 4
Fix for the Atari 5200 - Games datfile - Ballblazer
« on: June 16, 2011, 07:53:11 PM »
Hello from a fresh new contributor!

Recently I've discovered an interesting issue regarding the Atari 5200 Ballblazer dumps that should be interesting for you.

The cartridge that's listed under the name "Ballblazer (1986)(Atari - Lucasfilm)" is actually a bad dump. It has a bug - it sometimes displays three goalposts instead of two. A picture is worth more than a thousand of words, so I'm attaching the screenshots (from Atari800 2.2.1) that show the bug.

The other cartridge (currently named "Ballblazer (1986)(Atari - Lucasfilm)[a]") does not have this bug. Therefore I'm suggesting renaming "Ballblazer (1986)(Atari - Lucasfilm)" to "Ballblazer (1986)(Atari - Lucasfilm)[b double goalpost]" and "Ballblazer (1986)(Atari - Lucasfilm)[a]" to "Ballblazer (1986)(Atari - Lucasfilm)".



Offline Cassiel

  • Administrator
  • Hero Member
  • *****
  • Posts: 1450
    • Email
Re: Fix for the Atari 5200 - Games datfile - Ballblazer
« Reply #1 on: June 20, 2011, 02:36:32 PM »
Thanks for the info!

Is this something you’ve just personally noticed (the graphics glitches), or is this something that’s been discussed on an Atari forum somewhere?

The reason I’m asking is I’m not entirely convinced of your conclusion…. The image ‘Ballblazer (1986)(Atari - Lucasfilm) is the same file hosted on AtariAge as well as included in No-Intro and various other places. The image ‘Ballblazer (1986)(Atari - Lucasfilm)[a]’ appears to be 4 (I think from memory) bytes different, which could easily indicate that it has been dumped incorrectly, though it could just be a valid alternative version.

I know there is also a prototype version of this game that exists (though not in TOSEC yet) but I know for a fact neither of these images are that proto.

I’m not a big Atari fan or follow ‘the Atari scene’ or anything, so please say if you think I’m barking up the wrong tree.

Offline Symmo

  • TOSEC Contributor
  • Jr. Member
  • **
  • Posts: 55
Re: Fix for the Atari 5200 - Games datfile - Ballblazer
« Reply #2 on: June 21, 2011, 09:21:57 AM »
[quote (from Atari800 2.2.1) that show the bug. <- does say 800 so maybe a  (emulation) hardware issue?

[/quote]
Maybe its like hardware scrolling error?
Because its checked floor u dont notice it much idk maybe a pal/ntsc thing?.
I had a google and found nothing myself .
When i look into the pic i see if repeating the post from the right left of screen and and reveresed to right side same gap.
« Last Edit: June 21, 2011, 09:28:34 AM by Symmo »
Try this as your wallpaper if you are new :-) http://symmo.net/tosec/tosectnc.png

Offline Kr0tki

  • Newbie
  • *
  • Posts: 4
Re: Fix for the Atari 5200 - Games datfile - Ballblazer
« Reply #3 on: June 21, 2011, 09:08:10 PM »
Is this something you’ve just personally noticed (the graphics glitches), or is this something that’s been discussed on an Atari forum somewhere?
Nah, I've noticed it myself.

The reason I’m asking is I’m not entirely convinced of your conclusion…. The image ‘Ballblazer (1986)(Atari - Lucasfilm) is the same file hosted on AtariAge as well as included in No-Intro and various other places.
The fact that this image is widely published doesn't means much, I believe. Most images published on various websites are, most likely, copies of the same ROMs that circulated on BBSes and newsgroups from at least mid-nineties. To this day, on the 5200 scene there never was any coordinated effort to dump and verify the cartridges for the system. (On the sister system, the Atari 8-bits, a similar effort only started a year ago - all in this thread @AtariAge.)

AFAIK, the images at AtariAge were not dumped by Albert Yarusso - he just grabbed them from the Net.

A similar case is Atarimania.com (which is the first and currently the only project focusing on collecting only original Atari software). From the start of the project they focus their efforts on the Atari 2600, the 8-bits, and most recently on the ST. But for the 5200 they are only hosting the images that were available on the Net at the time.

The image ‘Ballblazer (1986)(Atari - Lucasfilm)[a]’ appears to be 4 (I think from memory) bytes different, which could easily indicate that it has been dumped incorrectly, though it could just be a valid alternative version.
Yup, exactly 4 bytes. Although the difference is really peculiar - in all 4 cases, the bytes differ only on bit 5. That is, on the [a] image the four bytes have bit 5 set to 1, and on the other image the four bytes have bit 5 set to 0. This is most likely a symptom of a bad dump, because the probability of such result by an intentional revision of source code is rather small, I believe.

I know there is also a prototype version of this game that exists (though not in TOSEC yet) but I know for a fact neither of these images are that proto.
AFAIK the protos were never released to the public, maybe Matt from AtariProtos still has them and would be kind enough to publish them?

(from Atari800 2.2.1) that show the bug. <- does say 800 so maybe a  (emulation) hardware issue?
All three leading emulators (Altirra, Atari800 and Atari++) show this bug. Altirra is being hailed as the 99.99% accurate emulator (and rightly so), so it's unlikely that it's an emulator issue.

Because its checked floor u dont notice it much idk maybe a pal/ntsc thing?.
Definitely not - I've tested all emulators in NTSC. (5200 is an NTSC-only system.)

Offline Symmo

  • TOSEC Contributor
  • Jr. Member
  • **
  • Posts: 55
Re: Fix for the Atari 5200 - Games datfile - Ballblazer
« Reply #4 on: June 22, 2011, 09:50:20 AM »
Hi
ok i dont know the system but i did try atari800 2.1.0 linux .
Anyways i agree and u think 3 goal post is tuff ? i know a hack to get 4 :-)
Its the distance out in your pic u about 2 squares out go about 1.5 u get 4 flickering and stuff.
I tried with [a] version and didnt do it .
So yes i agree there is something different there.
« Last Edit: June 22, 2011, 10:10:55 AM by Symmo »
Try this as your wallpaper if you are new :-) http://symmo.net/tosec/tosectnc.png